[Solved] Packard Pla-Mor Set-Up Issues

Home Forums Wallbox2mp3 installation [Solved] Packard Pla-Mor Set-Up Issues

Viewing 36 reply threads
  • Author
    Posts
    • #48116
      simong_uk
      Participant

      Sorry guys, me again 🙂

      I’ve just received my Wallbox2mp3 (1.4) kit for our Pla-Mor box and followed the instructions fir modifying to unit.

      It’s partly working, but when I apply power to the board it automatically starts playing a track. If I press the reject switch on the board the same track just repeats and if I change the select to another track and press the reject switch again it just continues to repeat the original track.

      If I power off the unit, move the select to another track and re-power the unit, that track plays but again just loops and I’m unable to stop this playing or select any other tracks.

      Have I wired something incorrectly ?

      I don’t have any flashing error lights, but I did notice a very small red LED in the daughter board just above the reject switch that appears to be flickering.

      Any help really appreciated as this is the first wall box I’ve modded and its for my wife Xmas present ….. hoping its not a faulty board as that took ages to arrive from France.

      Many thanks in advance

    • #48117
      simong_uk
      Participant

      Photos attached ….

    • #48118
      simong_uk
      Participant

    • #48119
      Klaatu
      Keymaster

      Looks like a contact that stay closed.
      Did you put it in free play ?
      Add a new switch for credit ? Wrong switch that stay closed.

    • #48121
      simong_uk
      Participant

      Hi 🙂

      Ive not added any mods for free play yet, just installed the kit as per instructions …… free-play was next on my list after I’d confirmed everything was working OK.

      Ive checked the voltage on the fuse next to the coin switch on the right and it’s only about 0.75v …. does that sound right ?

      5v in all other places

    • #48122
      simong_uk
      Participant

      Ignore that – I just re-checked and its around 2.3v on the fuse

    • #48123
      simong_uk
      Participant

      Hmmm …. now the voltage on the fuse now reading 1.5v ….. something doesn’t seem quite right

    • #48124
      simong_uk
      Participant

      OK, if I remove the fuse near the coin switch it stops but-plaing the same track and the very small LED on the daughterboard of the Wallbox card stops flickering – Could it be that I have a faulty / shorted coins switch ?

      If so, how can I prove it and  if faulty can I bypass it completely with a momentary switch ?

      Many thanks

    • #48130
      simong_uk
      Participant

      Sorry for the multiple posts, but I’ve made some progress and discovered another issue.

      I remove the small metal cover in front of the coin switch and found the leaves in the switch are quite badly bent causing them to stick in the closed position, so Ive bypassed the switch completely with a momentary switch (my plan anyway) and that seems to have solved that issue.

      However, I have another issue where track 1 plays track 2, track 2 plays 3 and things remain like this until track 9 when everything lines up correctly. This appears to a very similar issues that another forum member reported here;

      http://www.wallbox2mp3.com/en/forums/topic/packard-mp3-not-working-correctly/

      It’s odd that I’m having the same issues, so could this be a software problem ……. or did I inadvertently buy the other member faulty Player-More ? 😉

    • #48131
      Randy
      Participant

      Have you checked the voltage at each contact to confirm a consistent drop of around .2-.4v from  1 to 24?

      Randy

    • #48132
      simong_uk
      Participant

      Yep, checked that and the voltage drops by around the same amount on each contact.
      noticed that one track doesn’t play at all even though I’ve confirmed it’s on the memory card and another seems to play in two positions –  its a bit odd

      I could cheat and just move the track cards around to match, but that doesn’t really fix the issue

    • #48133
      Randy
      Participant

      Nuts, I have not encountered this issue on the two I have done so I have not had to solve it.  All I can think of is to recheck the signal and ensure it is correct at the emulator itself on the signal and earth terminals to ensure it is getting from the contact disk in the box to the emulator correctly.  On mine the signal ranges from around .22 v up to 5.38 v – is that similar to what you are seeing? If the signal is getting to the emulator correctly it may be a bad board.

      Maybe the contacts or pickup arms on the inside of the contact disk are dirty? You basically have to disassemble the unit to clean those effectively.

      Randy

    • #48134
      simong_uk
      Participant

      Thanks Randy

      ill re-check the voltages to see what range they’re in.

      with regards to it possibly being dirty contacts, that crossed my mind but the fact that the unit recognises the trance changes when the selector is turned would indicate that contacts being made …. the first 9 tracks just seem to be one place out.

      I was wondering if a faulty resister could be the issue, i.e. if one was not resisting any current could that cause the track positions to shift by one place ?

      I’ll do some further investigation and let you know the outcome

    • #48136
      Randy
      Participant

      Just to be sure we are on the same sheet of music, if you are measuring the voltage input to the emulator at the left black GND and white SIG terminals on the emulator and consistently getting the same results as in the next picture then I would say the problem lies with the emulator.  If you are not consistently getting correct voltage input for each selection then it is somewhere in the wallbox.  Possibly a bad resistor.

    • #48139
      simong_uk
      Participant

      Hi Randy

      Thanks again for the help.

      I’ve checked voltages on the card as per your instructions and generally back track selection changes to voltage by 0.2v.

      However, I there is a discrepancy on track 10 where the voltage only increases by 0.07v, as per the below ….

      1. 0.2
      2. 0.4
      3. 0.6
      4. 0.8
      5. 1.0
      6. 1.2
      7. 1.4
      8. 1.6
      9. 1.8
      10. 1.87
      11. 2.1
      12. 2.27
      13. 2.47
      14. 2.67
      15. 2.87
      16. 3.2
      17. 3.3
      18. 3.5
      19. 3.7
      20. 3.9
      21. 4.1
      22. 4.3
      23. 4.5
      24. 4.7

      I’m not an electrons expert, but would this indicate that one of the resisters is faulty on selector 8?

    • #48141
      simong_uk
      Participant

      OK, I’ve made some progress 🙂

      I checked the resisters and one tone between 8 & 9 was giving a reading only half that all other showed so I assumed it was faulty. However, after loosening & re-tightening the connection it was reading fine.

      Now all selections give a 0.2v variance, so 1 gives 0.2v and 24 is giving 4.7v.

      Tracks 4 to 24 now play correctly, however, tracks 1 to 3 are still not right and play as follows;

      • Track 1 plays track 2
      • Track 2 plays track 1
      • Track 3 plays track 4
      • Track 4 plays track 4

      I’m away for a couple of days, but at the weekend I’ll try remaking all the connection, but I’m still a bit baffled as they all appear to give the correct readings now !?

      On a different subject, has anyone managed to squeeze the emulator board inside of a Pla-Mor box ? ……. It looks very tight but I think it will just go, but I’ll need to make sure the lock mechanism doesn’t hit the card.

      Thanks again 🙂

       

    • #48143
      Randy
      Participant

      Well good – some progress right!

      As for mounting internally I personally have not tried as I like to keep them as original as possible.

      But a quick look with a spare unit I have on hand and it seems very possible.  You will obviously have to remove the coin box and probably the legs of the emulator.

      I have mounted one internally to a Buckley because there was enough room in that model to do so without removing anything original once I removed the legs and fashioned a small bracket to hold it in place.

      Of course you will need to find a place to mount the remote pot for volume control and the momentary switch.  With the coin box gone you could drill mounting holes in the back plate for those and mount them internally with access from the back of the box.

      I have seen others where the entire unit was simply screwed externally onto the back of the wallbox.  When sitting on a shelf it can be close to unnoticeable.

      Randy

    • #48156
      simong_uk
      Participant

      Hi Randy

      a bit of an update.

      I decided to glue the board to the rear of the wallbox as there was no way to mount it internally.

      I cleaned the selector contacts as best as I could without dismantling the unit (how do I remove the selector drum ? ) and I re-checked and tightened all resister and cable connections again but the issue has actually got worse now with the first 10 tracks being out by several positions, 2 tracks repeating in 2 positions, and nothing at all playing on selection 24 😩

      I’m going to rue-check the voltages again today, but feel I’m going around in circles with this issue and running out of time to fix before Xmas 🥺

      If the voltages check out ok again with 0.2v difference then what else would you suggest ? …. I notice that I’m only getting 4.67v max whereas you mentioned getting 5.38v, so could that be an issue ?

    • #48158
      Randy
      Participant

      Well that’s not good – but don’t give up hope.  To remove the drum there is a set screw on a collar on the middle of the drum under the song strips that screws into a hole on the shaft – see picture.

      I would just loosen the set screw and back of the drum a little to get at the contact points.

      Or just spray some contact cleaner in there and try to get at them with a cotton swab.

      You can also check that you are getting the proper resistance at each selection terminal, should progress by 100 Ohms as you go along.

      Randy

    • #48161
      simong_uk
      Participant

      Thank you Randy

      Struggled to get the drum off so gave up in the end.

      Currently the tracks play as follows ….

      1. =23
      2. =22
      3. =21
      4. =20
      5. =19
      6. =18
      7. =17
      8. =16
      9. =15
      10. =14
      11. =12 (Track 13 missing !)
      12. =10
      13. =9
      14. =9 (repeated)
      15. 8
      16. =7
      17. =6
      18. =5
      19. =4
      20. =3
      21. =3 (repeated)
      22. =2
      23. =1
      24. = Doesn’t play any track

      I’ve re-checked the voltages at the emulator card (gnd & signal) and they read as follows;

      1. 0.2v
      2. 0.44
      3. 0.65
      4. 0.86
      5. 1.08
      6. 1.29
      7. 1.5
      8. 1.71
      9. 1.92
      10. 2.13
      11. 2.34
      12. 2.55
      13. 2.77
      14. 2.77
      15. 2.98
      16. 3.19
      17. 3.34
      18. 3.61
      19. 3.82
      20. 4.03
      21. 4.12
      22. 4.33
      23. 4.54
      24. 4.75

      Interestingly, the voltages at selections 13& 14 and 20 & 21 are very similar which would explain why the tracks repeat

      I’ve tried measuring the resistance between each track selector post and these all read around 100 ohms, but if I measure from 1-2, 1-3, 1-4, 1-5 etc the value’s gradually increase until I get to 11, then there’s very little change until 14 when the value’s gradually start decreasing.

      I’m wondering if I should just replace all of the resisters and start again !?

      • This reply was modified 10 months, 1 week ago by simong_uk.
    • #48164
      Randy
      Participant

      You may have a bad batch of resistors or a broken wire.

      From the first post to the last should be a constant increase or 100 ohms per post up to an ending reading of 2300 on the 24 post.

      With the last resistor on the blue wire you should have a reading of 2400 ohms where the blue wire is grounded on the negative terminal.

    • #48172
      simong_uk
      Participant

      Thanks Randy

      Ive ordered some new resistors from Amazon which should be here tomorrow – if I get time tomorrow evening I’ll replace all of the resistors again and report back.

    • #48186
      simong_uk
      Participant

      Hi Randy – Update for you .. I removed all of the existing resistors, tightened all selector post nuts, installed a new set of resistors including replacing the one attached to the wire hidden in the insulation. Things have greatly improved in that 23 of the 24 tracks now play consistently in the same positions. However, the track numbers on the SD card still don’t match with the tracks played by the selector positions, ie 1 plays 23, 2 plays 22, 3 plays 21 etc and track 24 still doesn’t play anything. I’m therefore suspecting something’s not right with emulator card or the software used the copy the tracks the to memory card, but I’ve given up trying to 100% fix for now as I’ve run out of time to fix before Xmas. Gaelle has said they will send me a 1.5 board, so I’ll see if that fixes the issue once and for all, but for now I’m happy that it plays 23 of the 24 tracks and I’ve just moved the track cards around to reflect where the songs actually play …. this is fine, but I still want to fix.

      The conversions still not 100% complete as I’ve ordered a 1941 5 cent coin which I’m going to bond to the freeplay button – I’ll upload some photos on the box this evening 🙂

      • This reply was modified 10 months, 1 week ago by simong_uk.
    • #48188
      simong_uk
      Participant

      I meant to also thank you for your help on this issue 🙂

      Have a great Xmas & New Year

    • #48191
      Randy
      Participant

      Great, I’m glad it’s playing at at least close to right.  I’m sure we can get it 100% after Xmas.

      Randy

    • #48194
      Randy
      Participant

      After having thought about it some more I realized that I had been focused on voltage and resistance rather than song order, I missed that your songs were 180 degrees out of synch.

      I tried a simple experiment on mine and it appears that you may just need to change where you have the red and blue (or purple as it appears in you pic) wires connected.  Either at the 1 and 24 post end or the terminal block end – obviously not both.

      When I did this my songs were played backwards like you described.

      Might want to wait until after Xmas as it might make the whole thing explode.

       

      Randy

    • #48198
      simong_uk
      Participant

      Thanks Randy

      that’s a good suggestion ….. the odd thing is that the tracks are only reversed of the first 12 tracks or so, then the remaining tracks re in the correct order

    • #48199
      simong_uk
      Participant

      OK, here s a few photo’s of the finished project.

      I’ve mounted it on a wooden plinth and fitted two momentary switches – The left one is the Reject and the right one with the 1940’s coin in the free-play button.

      I failed at fitting the emulator board inside the unit as even though it would just about fit, it was obstructing the lock mechanism and metal locator lugs on the inside left/right of the front cover.

      In the end I mounted it on the rear of the cover using Powerflex Superglue which seems to be holding it better than I expected – I was concerned about drilling holes through the rear.

      I’ve also fitted a Bluetooth transmitter unit and purchased a retro bluetooth speaker (See photo) and this seems to work well. I did try powering the transmitter of the 5V on the emulator card but I ended up getting loud buzzing so opted to power it of an additional Amazon USB power adapter.

      Finally, I added a jukebox track selector sound effect to the beginning of each track to make the selection process sound a little more authentic

      This was my first attempt at a callbox conversion, and other than the still unresolved issue of tracks not playing in the correct order I’m pretty happy with how it turned out 🙂

    • #48200
      simong_uk
      Participant

    • #48201
      Randy
      Participant

      Well we might not have gotten to 100% on the mechanics but you have certainly exceeded the standard on presentation!

      You have a darn nice looking wallbox to start with and the setup is outstanding – good work.

      I really like the bluetooth idea, I have not tried that yet but that along with the record change lead in does a great job simulating the remote play the boxes were designed for.

      Randy

    • #48202
      Scudie
      Participant

      Hi Simong

      I have been following the progress of your project with interest,  sorry I have not been able to be any help with trying to sort out any of the issues that you have encountered, personally I have not worked on a Pla-Mor wallbox or do I have any knowledge on that particular emulator.

      I knew Randy had experience with the Pla-Mor set up, having done a couple of them so considered it best to leave it to him to offer advice and information.

      It does seem very strange that the first 12 selections play incorrectly while it would appear to correct itself from 13 to 23 and nothing for 24.

      Assuming that the emulator is (for the matter of configuration) the same as the standard emulator did you configure the Sd card for any random music?

      It is my oppinion that enabling the random function on the standard pre V1.5 emulators has a detrimental affect on the emulators ability to perform reliably. Also I presume that your not using one of the micro SD cards with an adapter as again these have been at the route of some problems.

      I do agree with Randy & congratulate you on your project, I think some one will be very happy with there Christmas present, it certainly looks the part👍

      Cheers Scudie

       

      • #48204
        simong_uk
        Participant

        Hi Scudie

        Thanks for the feedback 😊

        Ive not configured the SD card for any random play and I’m using the 4Gb card that came with the emulator card, so not a micro SD.

        Hopefully I’ll receive the 1.5 board in the new year, so it will be interesting to see if that resolves the issue.

    • #48203
      Klaatu
      Keymaster

      Congrats Simon, that’s a nice setup.
      Don’t know if it’s the photo angle view, but your drum titles holder seems not fully pushed to the left, if I compare with mine. Maybe it could affect contact inside…

      • #48205
        simong_uk
        Participant

        Thanks Klaatu 😊

        I’m pretty sure it’s located correctly as the the locator screw on the shaft is seated correctly and I think this would rule out it being too far to the right.

        However, you’ve given me an idea re the tracks playing in the wrong place ……. I’m wondering if at some point in the past the drum had been removed and when re-assembled it got turned 180 degrees …… or is the screw hole in the shaft only on one side making that impossible ?

    • #48206
      Randy
      Participant

      Took a look at the one I have disassembled – the hole is only on one side of the shaft.

      There is some play in the lateral movement of the drum on the other two I have.  Probably to allow the wiper arm some flex as it moves over the contacts.

    • #48210
      Scudie
      Participant

      Good morning Simong

      Well that rules out the two suggestions that I made, I wasn’t aware that the Pla-Mor kit came with an SD card, if it was me I would try another SD just to rule it out.

      Cheers Scudie.

    • #48356
      simong_uk
      Participant

      Hi Guys

      I just wanted to update you on the issues I had with the tracks not playing in the correct order and track 24 always being blank.

      This has now been resolved thanks to Gaelle kindly sending me a 1.5 board, so there was either a bug in the 1.4 code or I had a faulty board.

      All 24 tracks now play and in the correct order.

      As the 1.5 board is slightly smaller I tried to fit it inside the Pla-Mor but failed …… it’s just slightly too big. So the cards mounted externally on the back again.

      Thanks again for everyone’s help 🙂👍

    • #48357
      Randy
      Participant

      Great! Glad it is all good to go.  The folks at WB2MP3 have always been really helpful for me too.

      Randy

    • #48358
      Scudie
      Participant

      It’s good to hear that it’s now working as well as it looks, it’s a shame that it didn’t quite fit inside but I think it still looks great.

      Cheers Scudie

Viewing 36 reply threads
  • You must be logged in to reply to this topic.